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Introduction

This document shows how to use the JINBridgePro plug-ins for Visual Studio and for Eclipse to
generate proxies and to use them in larger projects. While JNBridgePro has always included an easy-
to-use standalone proxy generation tool, the fact that it was a separate tool from users’ main
development environment meant that proxy generation involved switching tools, which could be
inconvenient at times, and proxy generation was a separate activity from the building of projects in
the development environment. Consequently, many customers asked us for plug-ins that worked with
their development environments. Users can now generate their proxies within Visual Studio 2005,
2008, and 2010, and within Eclipse 3.2, 3.3, 3.4, 3.5, and 3.6, and use the generated proxies
seamlessly in their project builds.

This document assumes that the users are familiar with the JINBridgePro standalone proxy generation
tool, and with how the generated proxies can be used. For more information on these topics, please
see the examples that ship with the JINBridgePro installation, and also the Users’ Guide.

JNBridgePro plug-in for Visual Studio

The JNBridgePro plug-in for Visual Studio can be used with Visual Studio 2005, 2008, and 2010, and
is used in projects where .NET code is calling Java code. The example is taken from the “log demo”
that comes with the JNBridgePro installation. For more information on the log demo, please see the
document associated with it that comes with the installation

Generating the proxies

Start by creating your new solution, and a C# console application. Add the files App.config and
LoggerDemo.cs (Figure 1).

Solution Explorer » 1 X

= ealE
j Solution 'LogDemoExe’ (1 project)

4 7] LogDemoExe

. [=d| Properties

«d| References

i App.config
“#] LoggerDemo.cs

.:_T;| Solution Explorer § 5 Mt at (sl

Figure 1. Log demo project

Next, create a new proxy generation project. There are several ways to do this, but the simplest way is
to right-click on the solution node in the Solution Explorer, then select Add>New Project.... In the
Add New Project dialog box that now appears, note that there is a new project type, JNBridge, and a
new template, DotNetToJavaProxies. Select that template, then name the new project and assign it a
location (Figure 2).
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Recent Templates [.NEI' Framework 4 = ] Sort by: [Default EElE | Search Installed Templates

a DotMNetTolavaProxies INBridge Type: JNEridge

Installed Templates

Visual Basic
4 Visual C#
Windows
Web
Office
Cloud
Reporting
SharePaint
Silverlight
Test
WCF
Workflow
Visual C++
Visual F#
INBridge
Other Project Types
Database
Modeling Projects
Test Projects

Online Templates

Marne: Log Demo proxies

Location: CihternptLogDemo', -

Figure 2. Adding a new JNBridge proxy generation project

Note that the Solution Explorer now contains a new proxy generation project, and a new proxy
generation document, a .jnb file. This is the same .jnb file used by the standalone proxy generator
(Figure 3).

Solution Explorer

; Solution 'LogDemoExe’ (2 projects)
4 a Log Demo proxies
ﬁ] DotMetTolavaProxies.jnb
4 7 LogDemokExe
> [=d| Properties
» [+g] References
i App.config
#] LoggerDemo.cs

LT;;‘ Solution Explorer [§ 5 MEET =G0

Figure 3. After adding the proxy generation project
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Open the .jnb file by double-clicking on its node in the Solution Explorer. An editor window will
open in Visual Studio. Note that its layout resembles the GUI version of the standalone JNBridgePro
proxy generation tool (Figure 4).

File Edit View Project Build Debug Team Data Tools Architecture Test Analyze JMBridgePro Window Help
PGl S H@ % aR9 -0 -0-5] b b [Debug -| | Mixed Platforms -|| (2 |EditorPanel Load Bl o =

i NewWorkltem~ (3 = | o | (] Source Control Explorer [ | o, ] £5 9 @ 42 2]
DotNetTolavaProxiesjnb ~  Solution Explorer

Environment Erposed Proxies Signature 2=
-4 Selution 'LogDemokxe’ (2 projects)
4 51 Log Demo proxies
4] DothetTolavaProsies jnb
4 (5 LogDemokxe
> [=d| Properties
» |3 References

x0gj00] 3, R0 RnRs T

3 App.config
#) LoggerDemo.cs

Output

Show output from: | INBridge BIRREEY =
INBridgePro v6.@ (.NET 4.8-targeted) trial -
Copyright ® 2881-2811, JNBridge, LLC. All rights reserved. - 0x
There are 43 days left in your trial license.

License location: C:\Program Files (x86)\JNBridge\INBridgePro vé.@"

.. BB Class View

I} Pending Changes B Find Results1 & Find Symbol Results

ation successful.

Figure 4. After opening the .jnb file

Next, add the files log4j.jar and log4j-core.jar to the class path to be searched for proxy generation.
(You can download the log4j JAR files from http://jakarta.apache.org/log4j/docs/index.html.) Also
add the folder in which loggerDemo\JavaClass.class is to be found. Use the menu command
JNBridgePro—Edit Classpath.... (Alternatively, you can right-click on the .jnb file node in the Solution
Explorer and select Edit Classpath... or use the Edit Classpath button in the JNBridgePro toolbar.)
The Edit Class Path dialog box will come up, and clicking on the Add... button will bring up a dialog
that will allow the user to indicate the paths of the Jar and class files (Figure 5).
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Mew Classpath Element

Select a new folder orfile to add to the classpath:

l:l Frogram Files
I:I ProgramData

{21 System Volume Information
|_:_||:| temp |
=23 LogDema [

&-{Z Log Demo proxies

Bicad) jar
S oo dj-core iar
LogDemao ..h

m

[

----- {27 loggerDemo | 4
-0 Users [
{771 VPC images

4

C:temptLogDemo™ogdjcore jar C:temp*LogDemo™

Coce

Figure 5. Adding a new classpath element

When all the necessary elements of the classpath are added, the Edit Class Path dialog should contain
information similar to that shown in Figure 6.

Edit Class Path

CtempLogDemo“ogdj-core jar
C:\temp'LogDemo'log4j jar
C:tempiLogDema

Add system CLASSPATH

Figure 6. After creating classpath
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The next step is to load the classes from each of the Jar files, and to add JavaClass. For the Jar files,
use the menu command JNBridgePro—Add Classes from JAR File... for each Jar file. For a single class
such as JavaClass, use the menu command JNBridgePro—Add Classes from Classpath... and enter the
fully qualified class name loggerDemo.JavaClass (Figure 7). (You can also accomplish these actions
by right-clicking on the .jnb file node in the Solution Explorer, or by clicking on the appropriate
button in the JNBridgePro toolbar.)

Add classes

Class name Supporting classes?

Enter class name here:

Include
loggerDemo JavaClass| supporting m
classes *

Figure 7. Adding a class from the classpath

Loading the classes may take a few minutes. Progress will be shown in the output window (in the
JNBridge sub-pane) in Visual Studio, and in the progress bar. When completed, the classes in the
log4j Jar files and loggerDemo.JavaClass will be displayed in the Environment pane on the upper left
of the editor (Figure 8). Note that JNBridgePro will warn us that we are missing a number of classes
relating to JMS (Java Messaging Service), XML, and JavaMail. Since we are not going to use these
capabilities of log4j, we can safely ignore this warning.
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Java.
Java.
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4

Project File

B Finc

Output [ TR

Ready

v The name of the file containing build,
configuration, and other information about the ..

Figure 8. After adding classes

We wish to generate proxies for all these classes, so when all the classes have been loaded into the
environment, make sure that each class in the tree view has a check mark next to it. Quick ways to do

this include clicking on the check box next to each
command JNBridgePro—»Check All in Environment.

package name, or simply by selecting the menu
Once each class has been checked, click on the

Add button to add each checked class to the list of proxies to be exposed. These will be shown in the

Exposed Proxies pane (Figure 9).
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Figure 9. After adding classes to Exposed Proxies pane

While one can build the proxies now, using the INBridgePro—>Build menu item, in this example, we
will wait until we have referenced the proxy generation project in the main executable’s project and
do the build as part of a build of the entire solution.

Using the proxies

Now that we have created the proxy generation project, we can reference the project from our main
project by right-clicking on the project node for our main executable and selecting Add Reference....
In the Add Reference dialog box, select the Projects tab, and select the proxy generation project.
Also, under the Browse tab, select jnbshare.dll and jnbsharedmem.dll from the JNBridgePro
installation folder (use the 4.0-targeted versions if you’re targeting .NET 4.0; use the 2.0-targeted
versions if you’re targeting .NET 2.0/3.0/3.5) and add them to the references (Figure 10).
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Solution Explorer * 1 X

_g Solution 'LogDemokxe’ (2 projects)
4 a Log Demo proxies
ﬁ1 DotMetTolavaProxies.jnb
4 _E LogDemokxe
=d| Properties
a | _ References
23 IMBShare
-3 JMBSharedMem
43 Log Demo proxies
A3 Microsoft.CSharp
- System
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A Systern.Data.DataSetExtensions
A3 Systern.Xml
4 System.Xml.Ling
i App.config
%] LoggerDemao.cs

l—“_i] Solution Explorer

Figure 10. After referencing the proxy generation project

Once that’s done, just build your solution. That’s all there is to it. The output of the proxy generation
project will be automatically used in your main executable’s project.

Once you’ve built the proxies, they will appear in Visual Studio’s IntelliSense when you program
against them. (If you haven’t yet built the proxy project, they won’t appear in IntelliSense until you
do.)

At this point, create, configure, and run your project as described in the “Log Demo” document.

Multi-targeting in Visual Studio 2010: In Visual Studio 2010, you can generate proxies and create
projects that target either NET Framework 2.0/3.0/3.5, or .NET Framework 4.0. To choose between
the two, right-click on the proxy generation project in Solution Explorer and select “Properties.” The
project property page will be displayed. Locate the Target Platform property, and select the target
framework from the pull-down (Figure 11). Dismiss the Property Pages box and rebuild the project.

10
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Log Demo proxies Property Pages i =
General 4
Project File Log Demo proxies.nbproj
Project Folder ChtempiLogDemno
Target Platform Microsoft .NET Framework v4.0 (all versions) El
Microsoft MET Framework v2.0/3.0/3.5
Microsoft MET Framewerk v4.0 (all versions)
Target Platform
The version of the Common Language Runtime to use for cutput assembly
[ oK ] ’ Cancel Apply

Figure 11. Specifying a target platform in Visual Studio 2010

JNBridgePro plug-in for Eclipse
The JNBridgePro plug-in for Eclipse can be used with Eclipse 3.2, 3.3, 3.4, 3.5, and 3.6, and is used
in projects where Java code is calling .NET code. The example is taken from the “Java-to-.NET” that
comes with the JNBridgePro installation. For more information on the Java-to-.NET demo, please see
the document associated with it that comes with the installation.

Before using the Eclipse plug-in, make sure it has been installed. Locate the file jnbridgepro6_0_0-
eclipse.zip in the “Eclipse plug-in” folder located in the JNBridgePro 6.0 installation folder. Open the
zip file and extract its contents (a folder “com.jnbridge.plugin.eclipse_1.4.0") to the plugins folder
inside your Eclipse installation.

If you are using the 64-bit version of Eclipse 3.6, you must use the 64-bit version of INBridgePro,
and you must add the following argument to eclipse.ini:

-vm C:/Program Files/Java/jre6/bin/javaw.exe

or use a path to some other 64-bit javaw.exe. Do not use the path to the javaw.exe that resides in
\Windows\System32.

Generating the proxies

Start by creating your main Java project. Here we will simply create a project and import the Java
files supplied in the Java-to-.NET demo (found in the file winFormDemo22.zip in the JNBridgePro
installation). Note that there are compilation errors because they reference proxy classes that do not
yet exist (Figure 12).

11
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t% Package Explorer 2 f: Hierarchy = 0O

4 h:‘f- Java-to-DotMet
a |7 src
4 @ SampleClient
- iyf| MainForm,java
- @] MessageWindowlListener.java
jnbcore_sharedmem.properties
run_SwingClient.bat
> B JRE Systern Library [JavaSE-1.5]

Figure 12. The initial project
Next, we will create our proxy generation project. Select the File>New->Other... menu item. The New

dialog box will appear. Note that there are two new items under the INBridge header: “Java to .NET
Interoperability Project,” and “Java-to-.NET Proxies” (Figure 13).

12
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= New l = |-
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Wizards:
type filter text
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» = CVS
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4 [= JMBridge

] Java te NET Interoperability Project
m Java to .MET Proxies

¢ [ Tasks

» = XKML

» [= Examples

b . .
@_} < Back Mext = Finish

Figure 13. Creating a new interoperability project

Select “Java to .NET Interoperability Project” and click on the Next button. Give the project a name,
and indicate its location. Do not reference any other projects.

Next, select the project node for the proxy generation. Right-click on the project node and select
New->Other.... In the New dialog box this time, select “Java to .NET proxies” and click on the Next
button. Again, select a name, but leave the location the same. The Package Explorer will now display
the new proxy generation project (Figure 14). Inside the project will be a .jnb file node. This
represents the same .jnb file that is used by the GUI-based standalone proxy generation tool.

13
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t% Package Explorer 2 f: Hierarchy = 0O

h;—,"f- Java-to-DotMet
G2 src
g SampleClient
@ MainForm.java
@] MessageWindowlListener.java
jnbecore_sharedmem.properties
run_SwingClient.bat
=i JRE Systern Library [JavaSE-1.6]
a Proxies
= bin
h proxies.jnb

Figure 14. After adding the new proxy generation project

At this point, an editor window for the .jnb file should be displayed in Eclipse (Figure 15). If it is not
displayed, you can display it by double-clicking on the .jnb file node in the Package Explorer.

14
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Copyright @ 2001-2011, JNBridge, LLC. All rights reserved.
There are 39 days left in your trial license.
License location: C:\Program Files (x86)\JNBridge\JNEBridgePro v6.0%

Figure 15. The proxy generation editor in Eclipse

Next, add the assemblies Swinglinterop.dll and System.Windows.Forms.dll to the assembly list to be
searched by JNBProxy. (We will be calling methods that are not defined in Swinglnterop.Form1 and
Form2, but rather in their superclass System.Windows.Forms.Form, which is defined in
System.Windows.Forms.dll.) Use the menu command JNBridgePro—Edit Assembly List.... (Make sure
that the proxy generation editor is active.) The Edit Assembly List dialog box will come up, and
clicking on the Add... button will bring up a dialog that will allow the user to indicate the paths of
Swinglnterop.dll (Figure 16). Alternatively, you can right-click on the .jnb file node in the Package
Explorer and select Edit Assembly List....

15
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Select a new folder or file to add to the classpath:

-4y Ped
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F-77 Java

m

C:empiSwingimtenop dot Met* Swinglnterop dll

Figure 16. Adding a new assembly list element

System.Windows.Forms.dll is in the Global Assembly Cache (GAC). Add it to the assembly list by
clicking on the Add From GAC... button, and selecting the System.Windows.Forms.dll from the
displayed list (Figure 17). If you have more than one version of the .NET Framework installed on
your machine, you may have more than one version of System.Windows.Forms.dll in the GAC; select

the appropriate one.

Select assemblies from GAC

MName

System.Web Services
System.Web.Services
System Web Services
System Windows . Forms
System Windows . Forms
System Windows.Forms D
Svetem Windows Fams [

Wersion
2000
1.0.5000.0
4000
2000
1.0.5000.0
4000
4000
4000

Culture

neutral
neutral
neutral
neutral
neutral
neutral
neutral
ries Al

PublicKeyToken =

bOXHF11db0ada
b035A11d50a3a
bOXHF11d50ada
b¥7abch61334e. .
b¥7abch61334e. .
b¥7abch61334e . M
J1bf3856ad364...
UhfiRRRAdRd T

< |

I

[ »

Figure 17. Selecting an assembly from the GAC
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Note that we are using the .NET 4.0 version of System.Windows.Forms. We can also choose the 2.0
version. Since we have chosen .NET 4.0, we need to make sure that the “.NET 4.0 Targeted”
checkbox is checked in the plug-in’s preferences (Figure 18).

e
| type filter text JMBridgePro - v
[» General i
b Ant | About INBridgePro | Java Options | e
[ Help
[ Install/Update
b Java : When producing .MET proxies, the only allowed channel is shared memory.
|INBridgePro | TCP/Binary and HTTP/S0OAP are not supported in this version. This will not
> Run/Debug effect channel options for the Visual Studic 2005,/2008/2010 plug-in or the
[ Tasks £
> Team Locate jvm.dll (required):
i Usage Data Collector C:\Program Files (x86)%Java\jred\bin‘client'jum.dll
Validation
[ XML

Locate the inbcore.jar file (required):

C:\Program Files (x86)\JMBridge'JMEBridgePro v6.04nbcore\jnbeore,jar

Locate the beel.jar file (required):
C:\Program Files (x86)\JMBridge'JMEBridgePro v6.04nbcore\beel-5.1-jnbridge.jz

Generate J25E 5.0-targeted proxies [ .MET 4.0 Targeted

4 1 | b

Figure 18. Targeting .NET Framework 4.0

When all the necessary elements of the classpath are added, the Edit Assembly List dialog should
contain information similar to that shown in Figure 19.

17
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Edit Assembly List

Ctemp'Swinglnteroptdoth et Swinglnterop.dl|

System Windows Forms, Version=4.0.0.0. Culture=neutral, Pu love Up

1| 1] [ 3

[ Add from GAC.. ]

Figure 19. After creating assembly list

The next step is to load the classes Form1, Form2, and JavaWindowEventArgs, plus the supporting
classes. Use the menu command JNBridgePro—Add Classes from Assembly List... and enter the fully
qualified class names Swinglnterop.Form1, Swinglnterop.Form2, and
Swinglnterop.JavaWindowEventArgs, making sure that the “Include supporting classes” checkbox is
checked for each (Figure 20). Alternatively, you can also right-click on the .jnb file node in the
Package Explorer and select Add Classes from Assembly List....

18
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Add classes

Supporting classes?
fes

Class name

Swinglnterop. Form

Enter class name here:

Include
Swinglrterop . Form?| supporting

classzes

Figure 20. Adding a class from the assembly list

Loading the classes may take a few seconds. Progress will be shown in the console pane in the bottom
of the window, and in the progress bar. (If you don’t see a console, select the window=>Show
View>Console menu item.) When completed, Form1, Form2, and all their supporting classes will be
displayed in the Environment pane on the upper left of the proxy generation editor (Figure 21). Note
that JNBridgePro will warn us that we are missing a number of classes. Since we are not going to use

these capabilities, we can safely ignore this warning.
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Figure 21. After adding classes

We wish to generate proxies for all these classes, so when all the classes have been loaded into the
environment, make sure that each class in the tree view has a check mark next to it. Quick ways to do
this include clicking on the check box next to each package name, or simply by selecting the menu
command JNBridgePro—Check All in Environment. Once each class has been checked, click on the
Add button to add each checked class to the list of proxies to be exposed. These will be shown in the
Exposed Proxies pane (Figure 22).
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Figure 22. After adding classes to Exposed Proxies pane

Unlike the standalone proxy generation tool, we do not explicitly generate the proxies; they will be
built automatically, as needed. In this case, for example, since Build Automatically was set, the build
takes place whenever the contents of the Exposed Proxies pane changes, as it did here.

Using the proxies

To use the proxies in another project, right-click on that project’s node in the Package Explorer and
select Build Path>Configure Build Path.... Select the Libraries tab, then click on the “Add JARs...”
button. A JAR Selection dialog box will be displayed. Navigate to the associated JNBridge project
node, then into its bin directory and select the proxy jar file (Figure 23).

21



Getting Started with the INBridgePro Plug-ins JNbrIdgeprO“‘

= JAR Selection — - l (B |-

Choose the archives to be added to the build path:

type filter text

s IE‘J- Java-to-DotMet
P a Proxies
4 [ bin
|| proxiesjar
|X] .project
h proxies.jnb

| ok || cancel

Figure 23. Adding a reference to the proxy jar file

One must also add the files jnbcore.jar and bcel-5.1-jnbridge.jar from the JNBridgePro installation to
the Java Build Path. Then, when one performs a build, the referencing project will use the proxy jar
file generated by the JNBridge project. If the INBridge project is out of date or has not yet been built,
it will automatically be build or rebuilt before being used.

Information concerning the generation of the proxies is displayed in Eclipse’s Console window. If the
build was unsuccessful, information describing the errors will be found there.
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