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Introduction 
This document shows how JNBridgePro can be used to construct a .NET console application that 
calls Java classes. The reader will learn how to generate .NET proxies that call the Java classes, create 
.NET code that calls the proxies and, indirectly, the corresponding Java classes, and set up and run the 
code.  

In the example, JNBridgePro is used to allow .NET code to call log4j, a Java-based logging package 
developed as part of the Apache project. There are a number of reasons one might want to do such a 
thing. The developer may feel that this package is the best one for the job. Another, more compelling 
reason, might be that the developer is integrating .NET classes with existing Java classes that already 
use log4j to log events, and it would be desirable to have the Java- and .NET-originated logging 
messages go to the same output. Additionally, use of log4j by both Java and .NET code would allow 
logging to be controlled from a single configuration file, rather than requiring Java and .NET logging 
to be controlled from separate configuration files. 

In this example, we assume an existing Java class, loggerDemo.JavaClass, that includes an instance 
method doIt() that sends a log message to log4j. We will create a .NET-based class, 
com.jnbridge.demos.logging.DotNetClass that includes its own instance method f() that also sends a 
log message to log4j. A .NET-based driver method calls both JavaClass and DotNetClass, and we 
will see how both Java- and .NET-originated logging messages are displayed on the same console 
output. 

Generating the proxies 
The first step in the process is to generate proxies for the classes in the log4j package, and for 
loggerDemo.JavaClass. Start by launching JNBProxy, the GUI-based proxy generator, then selecting 
“Create new .NET  Java project” when the “Launch JNBProxy” form is displayed (Figure 1). After 
doing this, the main form of JNBProxy is displayed (Figure 2). 

 

Figure 1. JNBProxy launch form 
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Figure 2. JNBProxy 

Next, add the files log4j.jar and log4j-core.jar to the class path to be searched by JNBProxy. (You can 
download the log4j JAR files from http://jakarta.apache.org/log4j/docs/index.html.) Also add the 
folder in which loggerDemo\JavaClass.class is to be found. Use the menu command Project→Edit 
Classpath…. The Edit Class Path dialog box will come up, and clicking on the Add… button will bring 
up a dialog that will allow the user to indicate the paths of the Jar and class files (Figure 3). 

http://jakarta.apache.org/log4j/docs/index.html�
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Figure 3. Adding a new classpath element 

When all the necessary elements of the classpath are added, the Edit Class Path dialog should contain 
information similar to that shown in Figure 4. 

 

Figure 4. After creating classpath 
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The next step is to load the classes from each of the Jar files, and to add JavaClass.  For the Jar files, 
use the menu command Project→Add Classes from JAR File… for each Jar file. For a single class such 
as JavaClass, use the menu command Project→Add Classes from Classpath… and enter the fully 
qualified class name loggerDemo.JavaClass (Figure 5). 

 

Figure 5. Adding a class from the classpath 

Loading the classes may take a few minutes. Progress will be shown in the output pane in the bottom 
of the window, and in the progress bar. When completed, the classes in the log4j Jar files and 
loggerDemo.JavaClass will be displayed in the Environment pane on the upper left of the JNBProxy 
window (Figure 6). Note that JNBProxy will warn us that we are missing a number of classes relating 
to JMS (Java Messaging Service), XML, and JavaMail. Since we are not going to use these 
capabilities of log4j, we can safely ignore this warning. 
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Figure 6. After adding classes 

We wish to generate proxies for all these classes, so when all the classes have been loaded into the 
environment, make sure that each class in the tree view has a check mark next to it. Quick ways to do 
this include clicking on the check box next to each package name, or simply by selecting the menu 
command Edit→Check All in Environment. Once each class has been checked, click on the Add button 
to add each checked class to the list of proxies to be exposed. These will be shown in the Exposed 
Proxies pane (Figure 7). 
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Figure 7. After adding classes to Exposed Proxies pane 

We are now ready to generate the proxies. Select the Project→Build… menu command, and choose a 
name and location for the assembly (.dll) file that will contain the generated proxies. The proxy 
generation process may take a few minutes, and progress and other information will be indicated in 
the Output pane. In this example, we will call the generated proxy assembly logging.dll. 

Using the proxies 
Now that the proxies have been generated, we can use them to access Java classes from .NET. 
Launch Visual Studio .NET (note that this development can also be done using the .NET SDK), and 
create a new C# console application project. Add references to the assemblies logging.dll (the one just 
generated) and jnbshare.dll (distributed with JNBridgePro). Add to your project the file 
rlm913_x86.dll or rlm913_x64.dll or both (depending on whether the application will run as a 32-bit 
process, a 64-bit process, or either one). When adding the rlm913 dll, make sure that its properties 
settings include “Copy always.” Add the file app.config to the project. It is an application 
configuration file that configures the .NET side of JNBridgePro. You may want to examine the 
settings (it is set to communicate with the Java side using tcp/binary communications, where the Java 
side is on the same machine as the .NET side and is listening on port 8085). Make sure that, 
depending on whether you are using .NET Framework 2.0 or 4.0, you have commented and 
uncommented the appropriate sections of the configuration file. Next, add a new class and enter the 
following C# code: 
using System; 
using org.apache.log4j; 
using java.lang; 
using loggerDemo; 
 
namespace com.jnbridge.demos.logger 
{ 
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 class LoggerDemo 
 { 
  static Category cat  
   = Category.getInstance("com.jnbridge.demos.logger.LoggerDemo"); 
 
  /// <summary> 
  /// The main entry point for the application. 
  /// </summary> 
  [STAThread] 
  static void Main(string[] args) 
  { 
   BasicConfigurator.configure(); 
 
   cat.info(new JavaString("Entering application")); 
   DotNetClass dotNetClass = new DotNetClass(); 
   JavaClass javaClass = new JavaClass(); 
   for (int i = 0; i < 5; i++) 
   { 
    dotNetClass.f(); 
    javaClass.doIt(); 
   } 
   cat.info(new JavaString("Exiting application")); 
  } 
 } 
 
 public class DotNetClass 
 { 
  static Category cat =  
   Category.getInstance("com.jnbridge.demos.logger.DotNetClass"); 
 
  public void f() 
  { 
   cat.debug(new JavaString("Logged from .NET")); 
  } 
 } 
} 

Note that strings passed to the info() and debug() methods need to be wrapped in a 
java.lang.JavaString() object. This is because info() and debug() both expect a parameter of class 
java.lang.Object, and the .NET string is not a subclass of java.lang.Object, while java.lang.JavaString 
is. See the user’s manual for more details. 

The proxies for the Java objects in log4j are used exactly as the original objects would be used in 
Java.  Note the following items of interest: 

• Proxies for the Java classes have namespaces identical to the package names of the original Java 
classes. Thus, we simply import the namespaces org.apache.log4j, java.lang, and loggerDemo, 
and afterwards can use the names of the Java classes. 

• Proxies for the Java classes Category, BasicConfigurator, and JavaClass are used in exactly the 
same way as the original Java classes would have been used. 

• The .NET class DotNetClass’s calls to the logger object cat will cause messages to be written to 
the same output as the messages logged by JavaClass. 

• When typing in the calls to the Java objects, Visual Studio’s IntelliSense facility will offer to 
complete the names of method calls in the same way that it would for calls to .NET objects 
(Figure 8), and will provide information on number and types of parameters. 
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Figure 8. IntelliSense method completion for Java calls 

After entering the code, build the project to obtain the executable. 

Running the program 
Running the program is simple. Make sure that JNBridgePro is properly configured on the .NET side 
(i.e., app.config has been added to the project – upon building the solution, app.config will be copied 
to your project’s build folder and renamed projectName.exe.config, assuming your exe file is 
projectName.exe) and on the Java side (i.e., that there is a copy of the properties file 
jnbcore.properties in the same folder as jnbcore.jar), and that the .NET and Java side configurations 
agree on the protocol and port to be used. Then, start up a JVM. Assuming that jnbcore.jar, log4j.jar, 
log4j-core.jar, jnbcore_tcp.properties and loggerDemo\JavaClass.class are in the same folder, we can 
start up the Java-side in a console window as follows: 
java –cp “.;log4j.jar;log4j-core.jar;jnbcore.jar” com.jnbridge.jnbcore.JNBMain 

In a separate console window, start up the .NET program. The Java console window will display 
logging messages originating on both the .NET and the Java side (Figure 9). Note that Figure 8(b) 
contains logging output that originated on both the Java and .NET sides. 
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Figure 9. (a) Running the .NET-side. (b) Running the Java-side. 

Using shared-memory communication. It is possible to run the Java side in the same process as the 
.NET side, using a shared-memory communication mechanism. This has several advantages: it’s 
much faster than the socket-based tcp/binary and http/soap mechanisms, and it’s not necessary to 
explicitly start up the Java side – it’s automatically done before the first call to a proxy. To use shared 
memory, stop the .NET and Java sides (if they’re still running), then open the app.config application 
configuration file. Comment out the <dotNetToJavaConfig> element whose “scheme” value is “jtcp,” 
and uncomment the <dotNetToJavaConfig> element whose “scheme” value is “sharedmem.”  You 
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will need to edit the “jvm,” “jnbcore,” “bcel,” and “classpath” values to reflect the locations on your 
machine of jvm.dll, jnbcore.jar, bcel-5.1-jnbridge.jar, and the jar files log4j.jar, log4j-core.jar, and the 
path to the folder containing the loggerDemo folder (which in turn contains JavaClass.class).  Once 
you have made the changes, build the project and start it.  It will run as before, even though the Java 
side has not been explicitly started, since the Java side is now running inside the .NET process. 

Secure communication using SSL. It is possible to configure secure communications between the 
.NET and Java sides through SSL (secure sockets library).  SSL in JNBridgePro provides data 
encryption, message integrity, and server communications. It is only available when using tcp/binary 
or http/soap communications (shared memory is inherently secure), and is only available when using 
.NET 2.0 and JDK 1.4 or later. For more information on secure communications, see the Users’ 
Guide. 

Please note that the procedure below assumes that the reader does not already have a certificate. If 
the reader already has a certificate, other procedures may be followed. 

To use SSL, first make sure that the example is configured to use tcp/binary communications, and 
that this is working. 

Once it is established that the application works with regular tcp/binary communications, we 
configure for SSL.  First, add the attribute useSSL=”true” to the <dotNetToJavaConfig> element in 
the app.config file. Also, add the javaSide.useSSL=true property to the jnbcore.properties file that 
you will be using when you run the Java side. Rebuild the .NET application to install the 
configuration information. 

Next, we must specify the X.509 certificate that will be used to coordinate the communications.  
Here, we will create a self-signed certificate for this purpose. If you already have a certificate, the 
process will be slightly different. 

First, create the certificate in a Java keystore. Assuming that the bin folder of a Java development kit 
is already in your execution pat, open a command-line window and navigate to the base folder for this 
example.  Then run the following command on the command-line: 
 keytool –genkey –keyalg RSA –keystore keystore 

You will be prompted for a password.  Enter mypswd. You will be prompted for a first and last name. 
Simply enter localhost (the name of the host that the .NET side will be contacting. You can leave the 
rest of the requested information blank. When it confirms the information, type yes, and when it asks 
for a key passwork, hit return to indicate that the password should be the same as the keystore 
password. You will now have a file keystore in your current directory. 

Since the key is self-signed, and not signed by a trusted certificate authority, we need to have it 
explicitly trusted by .NET. First, we need to export it into a certificate file. When in the same folder 
as before, enter from the command-line: 
 Keytool –export –keystore keystore –file myCertificate.cer 

You will be prompted for the password. Type mypswd. You will now have a file myCertificate.cer in 
your current folder. Right-click on the certificate file and select Install certificate. The certificate 
installation wizard will come up. Simply follow the instructions. 

We are now ready to run the program. Assuming you are still in the base folder of the log demo, and 
that you have edited the jnbcore.properties file in the current folder to include the property 
javaSide.useSSL=true, run the following command on the command-line to start the Java side: 
java –cp “.;log4j.jar;log4j-core.jar;jnbcore.jar” -Djavax.net.ssl.keyStore=keyStore  
-Djavax.net.ssl.keyStorePassword=mypswd com.jnbridge.jnbcore.JNBMain 



Demo: Calling a Java logging package from .NET 
 

  13 

The javaSide.useSSL property specifies that SSL should be used, and the additional options on the 
command line indicate where the certificates are obtained. Now, run the .NET side. Everything 
should work as before, but the communications between the two sides will now be encrypted, and the 
Java-side server will have authenticated itself to the .NET side. If secure communications cannot be 
established, either because the certificate cannot be trusted, or the Java side cannot properly 
authenticate itself to the .NET side, an exception will be thrown. 

Summary 
The above example shows how simple it is to integrate Java and .NET code and to run the resulting 
program. The example above shows how a program can log information from both Java and .NET 
using a common logging infrastructure. Such a strategy greatly simplifies development and 
debugging of code running on both Java and .NET platforms. 

Creating this program was accomplished in three stages: 

• In the first stage, proxies were generated allowing access by .NET classes to the Java classes. The 
proxies were generated using JNBProxy, a visual tool that allows developers a wide variety of 
strategies for determining which Java classes are to be exposed to access by .NET. 

• In the second stage, the .NET assembly containing the proxies was linked to the .NET 
development project and .NET code accessing the Java classes was developed. .NET classes can 
access Java classes transparently, as if the Java classes were themselves .NET classes. Nothing 
special or additional needs to be done to manage Java-.NET communications or object lifecycles. 
Benefits provided by Visual Studio .NET, such as IntelliSense, are also available when writing 
.NET code that accesses Java classes. 

• In the third stage, the integrated .NET and Java code is run. All that is required is to start a Java-
side containing the Java code to be accessed and an additional support module (jnbcore.jar). Once 
the Java-side is started, the user simply runs the .NET program that will access the Java objects. 

By allowing Java and .NET code to interoperate, JNBridgePro helps developers derive full value 
from their existing Java code, even as they take advantage of Microsoft’s.NET platform. 
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